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SkyMap 1.0

1.  Introduction

SkyMap is a powerful "Planetarium" program for Microsoft Windows.  It will display a map 
of the sky as seen from any point on Earth for any date between 4000BC and 8000AD.  Once
drawn, the user can get information about any object displayed on the map simply by 
pointing at the object with the mouse and clicking the button.

Unlike other programs of its type which are on the market, SkyMap specifically doesn't claim
to be blindingly fast; to be able to draw a map in 1 second, or any of the other speed claims 
you've probably seen.  What it does claim to be is one of the most accurate programs of its 
type.  It uses the most rigorous methods that I could find for all its calculations.  Examples of 
this are:

1.  The planetary positions computed by SkyMap will generally differ from those published 
in the "Astronomical Almanac" by less than half a second of arc.  (For comparison, the 
apparent diameter of Neptune, as seen from Earth, is about 2", whilst that of Jupiter varies 
between about 30" and 45".).  

2.  Many astronomy programs currently available only compute geocentric planetary and 
lunar positions, making them effectively useless for such tasks as viewing eclipses and 
occultations.  SkyMap rigorously computes topocentric coordinates - coordinates as seen 
from the actual location of the observer - thus allowing solar eclipses, for example, to be 
viewed.

All of these features have been designed to allow SkyMap to be used by the serious amateur 
or professional astronomer as well as by the novice, although the program is (I hope!) 
sufficiently "user friendly" for the novice to use just to answer questions like "what's that 
bright object up there?".

The program carries out its calculations in as efficient as manner as possible, but it never 
compromises precision for the sake of speed.  An increase in speed can always be achieved 
by using a faster computer!  Having said all that, the speed is still reasonable; on the author's 
33MHz 486-based PC for example, the horizon map, with default settings, is computed and 
drawn in just over 4 seconds.

This is the first released version of SkyMap and as such, whilst offering a usable set of 
features, it is definitely not a finished product.  The reason I'm releasing it now is to ask for 
comments on its current features, and suggestions for new ones.

Although I am releasing SkyMap as Shareware, I quite appreciate that you may not consider 
it worth paying any money for in its current form.  I would obviously like to be paid the 
registration fee - I've put a great deal of work into this software - but I would still appreciate 
receiving your feedback on the program even if you feel it's not currently worth registering.  
If you do feel this way I'd like to know what, if anything, I could do to make you change your
mind in the future!
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2.  System Requirements

SkyMap requires Microsoft Windows version 3.1 or above to run.  It will not work with 
Windows 3.0 or earlier.

A maths coprocesser is not actually required to run SkyMap, but is definitely recommended.  
SkyMap does a great deal a great deal of trigonometry while creating maps, and use of a 
coprocessor can speed up this process by a factor of ten or more!

SkyMap will work with any type of display supported by Windows, but the best results will 
be achieved with VGA or better (SuperVGA, 8514/a, etc).

Maps can be printed on any type of printer supported by Windows.  Obviously, the best 
results will be obtained from a laser printer, but perfectly acceptable results will be obtained 
from a 9-pin or 24-pin dot-matrix printer, too.
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3.  Data Sources

The sources of the data used by SkyMap are as follows:

Stars

Smithsonian Astrophysical Observatory (SAO) star catalog,  (SAO Staff, 1966), 1990 
machine readable version, as supplied on NASA's National Space Science Data Center's 
"Selected Astronomical Catalogs, Volume 1" CD-ROM.

The SAO star catalog is a catalog of 258,997 stars to epoch J2000.0, and is reasonably 
complete down to magnitude 9.5-ish.  The star database supplied with this version of SkyMap
contains all the stars from the SAO catalog down to magnitude 7.0 - a total of 15,931 stars.  
Larger databases, up to and including the full SAO catalog, will be supplied to registered 
users of this software on request. (The database derived from the full catalog is roughly 
5.2MB in size.)

Planets

The positions of the Sun, and of the planets Mercury to Neptune are computed using a subset 
of  Bretagnon and Francou's VSOP87 planetary theory, as described in the book 
"Astronomical Algorithms", by Jean Meeus (Willman-Bell, 1991).

Moon

The position of the moon is computed from the ELP 2000-85 lunar theory (Chapront-Touzé 
and Chapront, 1988), which in turn is fitted to the DE200/LE200 numerical integration of the 
Jet Propulsion Laboratory (Standish, 1981).

5



SkyMap 1.0

4.  Contacting the Author

I would prefer you to contact me by e-mail if you are able to.  I can be reached at any of the 
following addresses, in decreasing order of preference:

Internet: chris@chrism.demon.co.uk
BIX: cmarriott
CIX: cmarriott
CompuServe: 100113,1140

If you don't have access to e-mail on any of the above systems, or you'd like to become a 
registered used of this software (see below), my postal address is:

Chris Marriott
9, Severn Road
Culcheth
Cheshire WA3 5ED
United Kingdom
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5.  Registering SkyMap

I have put a tremendous amount of work into SkyMap.  If you use the program on a regular 
basis, and you find it useful, please show that you appreciate this effort by paying the 
registration fee, as follows:

UK Elsewhere
Personal Use £15 £20 or $40US
Club Use £25 £30 or $60US

Personal registration allows the program to be used by one person.  You may install the 
software on any number of computers, as long as only one will be in use at any one time.

Club registration allows free use by all members of an astronomy club (or, indeed, any other 
sort of club!), on any number of computers, whilst at club meetings.  Any club member who 
wants to use the program at home is still expected to register the program personally.

The reason I'm asking more from overseas users is simply to cover the additional cost to me 
of sending you the registration goodies by air-mail.

Now, read this next section carefully please - it's a bit complicated!

If you live in the UK, or have a UK postal address, you pay the "UK" fee.  Send either cash 
or a cheque made payable to "Chris Marriott" to the address above.

If you live overseas, you have two choices about how to pay the "Elsewhere" fee:

1.  Send me British currency, or a cheque in £ sterling drawn on a British bank, for the £ 
registration fee.

2.  Send me cash, either for the $US fee, or the equivalent amount in your local currency 
(provided it's something exchangable - no roubles, etc!).  The reason this amount is a bit more
than the £ equivalent is because I have to pay a fee to change foreign currency.

I'm sorry, but I'm not able to handle credit cards.

Anyone who registers the program will receive from me:

1.  A personalized version of the program with your name in the "About" box, and your 
geographical location and time zone as the default observation location.  When you register 
the program, don't forget to tell me what these are, and what disk format (3.5" or 5.25") you'd
like me to send you.

2.  A larger version of the star database with a much fainter limiting magnitude.  With the 
registered version of the program I'll send you the largest star database that will fit, 
compressed, on a single disk of the format you've requested.  If you'd subsequently like an 
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even larger one, tell me either what limiting magnitude you'd like, or how big a file you'd 
like, and I'll send it to you for a small fee, to cover the cost of the disks plus postage.  
Remember though, the size of the catalog shoots up fast with limiting magnitude!  The 
database containing all 258,997 stars in the SAO catalog is roughly 5.2 megabytes in size.

3.  A nice bound, laser-printed version of this manual.

4.  The right to upgrade to any later version of SkyMap for a nominal fee.

5.  "Preferential" consideration of any suggestions you might have for enhancements to the 
program!

Please see the section of the manual entitiled "Contacting the Author" for details of where to 
send the registration fee to.
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6.  Installing SkyMap

On the SkyMap disk (or in the ZIP file if you obtained it from a BBS or other on-line system)
you should have the following files:

README.1ST Read this file first!
SKYMAP.EXE Main SkyMap program.
SKYMAP.HLP On-line help file.
STAR.SKY Main star database.
STARNAME.SKY Star name database.
STARPROP.SKY Star proper name database.
CONFIGUR.SKY Constellation figures database.
CONNAME.SKY Constellation name database.
MOON.SKY Moon position database.
PLANETS.SKY Planet position database.
CTL3D.DLL 3D Control library.
MWSPIL.DLL Spin button control library.
SKYMAP.WRI This manual.

To install SkyMap, carry out the following steps:

1.  Create a directory on your hard disk.  For the purposes of this discussion, we'll assume this
is directory C:\SKYMAP.

2.  Copy all the SkyMap files into this directory.

3.  Select the Program Manager group you'd like to add the SkyMap icon into.

4.  From the Program Manager's "File" menu, select "New...".  A dialog box will appear.  
Select "Program Item" (this should be the default, anyway) and press the OK button.

5.  The "Program Item Properties" dialog will appear.  Fill it in as shown below, then press 
the OK button.

6.  The SkyMap icon (a picture of a telescope) should appear in the Program Manager.  
SkyMap is now installed.
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7.  Configuring SkyMap and Displaying your First Map

When SkyMap is run for the first time, you must configure it for the your location.  Before 
SkyMap can correctly draw a map of the sky for you, you have to tell it where you are, and 
what time zone you are in.  To configure the program, carry out the following steps:

1.  Run SkyMap by double clicking on its icon in the Program Manager.  The empty SkyMap 
main window should appear, looking something like this:

The grey area at the bottom of the map is the status bar, used to display information to the 
user.

2.  From the File menu, choose "New Map".  An empty black map window will appear, and 
additional items will appear on the menu bar, as illustrated below:

Note that the message "Press F5 to draw the map" has appeared on the status bar.  Ignore this 
message for the time being!

3.  From the "Options" menu, choose "Observer...".  The Observation location dialog box will
be displayed:

Fill in your longitude and latitude, each in degrees, minutes, and seconds.  You need not be 
exact - a position correct to the nearest degree is fine unless extreme accuracy is required.

In the "Local Time" box enter your time zone, expressed in minutes ahead or behind 
Universal Time (UT), commonly called Greenwich Mean Time (GMT).  Eg, if your time 
zone is Eastern Standard Time, you are 5 hours behind UT, so you would enter "300" (5x60) 
into the text box, and click the button to change the display to read "behind UT".

If Daylight Saving Time (called "Summer Time" in the UK) is currently in operation, check 
the appropriate box.  If it is not currently in force, leave the box blank.

Note that if you are using a registered version of the program, this dialog should already 
contain the correct information for you.  All you will have to fill in is the "Daylight saving 
time" check box.

4.  Finally, you should save the information you've entered.  From the "File" menu, choose 
"Save Defaults...".  A box will appear asking you if you really want to save the information:

Press the "Yes" button.  The information will be saved in a configuration file called 
SKYMAP.INI and will be used as the default values for all maps subsequently drawn.
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5.  Press the F5 key.  A "Please wait" box will be displayed for a few seconds (depending on 
the speed of your computer), after which a map of the southern part of the sky as it currently 
looks from your location will appear in the map window.  If you maximize the map window, 
you should see something like this:

Note the following features of this map:

1.  Along the bottom of the map is the horizon, with the compass points displayed along it.  
By default, the program displays a view of  roughly one third of the sky, centred on the 
southern horizon.  The zenith is at the top of the map.

2.  Stars are displayed as dots of differing sizes.  The brighter the star, the larger the dot.  By 
default, stars down to magnitude 5.0 are displayed, although the star database supplied with 
the program contains stars down to magnitude 7.0 (fainter for the registered version of the 
program).

3.  By default, constellation names and figures are displayed.  These can both be switched off 
using the items on the "View" menu.

4.  Planets are shown as dots, with the standard astronomical symbol alongside.  Venus can be
seen towards the right side of the map shown above.  The Moon (not visible on the above 
map) is displayed with its correct phase.  The Sun (also not visible above) is displayed as a 
hollow circle.

5.  The status bar at the bottom of the window displays information about the map, such as 
the time and date, and the coordinates of the map centre.

11



SkyMap 1.0

8.  Drawing a Horizon Map

To draw a map, the following steps should be followed:

1.  From the "File" menu, choose "New Map" to create a new map window.  This will 
initially be blank.

2.  Use the items on the "Options" menu to set all the options required for the map.  These 
options are described below.  Once all the options have been set, you can save them to be 
used as the defaults for all future maps by selecting the "Save Defaults..." option from the 
"File" menu.

3.  When all the options have been set, press the F5 key to draw the map.  This process will 
take anything from a few seconds to (in extreme cases!) several minutes, depending on both 
the speed of your computer, and the complexity of the map.

4.  When the map appears, you can zoom in or out on it, identify objects on it, or print it.  
These options are described in the next section of the manual.

The items on the "Options" menu are as follows:

Viewpoint....

The Viewpoint option allows the user to specify which part of the sky appears on the map.  
When this option is selected, the following dialog is displayed:

The "Altitude" and "Azimuth" fields specify the coordinates of the map centre.  Altitude is 0°
at the horizon and 90° directly overhead.  Azimuth is 0° due north, and increases eastwards.

The "Radius" field specifies the vertical size of the map.  The altitude range of the map will 
be from (Centre-Radius) to (Centre+Radius), and the azimuth range will scale accordingly.

Notes:

1.  Even if the radius is greater than the centre azimuth (ie, Centre-Radius<0), objects below 
the horizon will not be displayed.  All that will happen in this situation is the horizon line will
appear higher up the map.

2.  To display a circular map of the whole sky, enter a centre altitude of 90°, and a radius of 
90°.

Time....

The time and date of observation are initially set from the computer's clock when the map is 
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created (ie, when the "New Map" option is selected).  The Time option allows the user to 
change these default values.  When this option is selected, the following dialog is displayed:

Fill in the dialog fields to the time and date required.  Pressing the "Now" button resets the 
time and date to that currently read from the machine's clock.

Notes:

1.  Dates BC should be entered as negative numbers, in the conventional astronomical 
manner.  1BC is the astronomical year 0, 1000BC is the astronomical year -999, and so on.

2.  Dates before 0h on 15th October 1582 are assumed to be in the Gregorian calendar; dates 
before then in the Julian calendar.

3.  The observation time is assumed to be a local time - ie, the time as shown on an observer's
clock.  The time zone information specified on the Observation Location dialog (see below) 
is used to convert the time to UT.

Observer....

The Observer option allows the user to specify the location from which the observation is 
taking place.  When this option is selected, the following dialog is displayed:

The Latitude and Longitude fields specify the location of the observer.  Both are entered in 
degrees, minutes, and seconds although, unless extreme accuracy is required, a position 
correct to the nearest degree will normally suffice.

The "Local Time" data specifies the time zone the observer is in.  It is used to convert the 
time of observation (which is always assumed to be local time) into UT or GMT.  The time 
difference is entered in minutes (not hours!) difference between local time and UT.

The "Daylight saving time" box should be checked if DST (called "Summer Time" in the UK,
and perhaps other countries too) is currently in operation.  If the box is checked, the local 
time is assumed to be an extra hour ahead of UT.

Stars....

The Stars option controls both which stars are plotted on the map, and the way that plotted 
stars are displayed.  When this option is selected, the following dialog is displayed:

The "Limiting magnitude of map" field determines the magnitude of the faintest star whose 
position will be calculated.  The higher the number, the greater the number of stars (and the 
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longer the map will take to compute).

The "Limiting magnitude displayed" field determines the magnitude of the faintest star that 
will actually be displayed on the map.  This can be used to temporarily omit the fainter stars 
on a map.  The value in this field must be less than or equal to the value in the previous field.

The lower half of the dialog box controls the way that the size of the star images varies with 
their magnitude.  All stars brighter than the first "Display mag" field will be displayed using 
the size of star circle shown to its right.  All stars fainter than the second "Display mag" field 
will be displayed using the size of star circle shown to its right.  All stars with magnitudes 
between these two limits will be drawn with an image size proportional to the magnitude.

Constellations....

This option allows the user to choose the font used for constellation names.  Selecting this 
option displays a standard font selection dialog.

Labels

Selecting this option displays a submenu of labelling options.  If the "Altitude" option is 
selected, the following dialog is displayed:

The "Label type" radio buttons allow the type of altitude labelling to be selected.  The options
are:

Automatic The label interval is selected automatically.
Every ... The label interval is specified in the text box.
Nothing No altitude labels are displayed.

If the "Draw Altitude Lines" box is checked, altitude lines are drawn across the map at the 
appropriate (manual or automatic) intervals, and the lines are labelled at the left-hand side of 
the map.

If the box is blank, altitude tick marks are drawn in the centre of the map.

Notes:

1.  If the "Nothing" box is selected, neither altitude lines nor labels are drawn, regardless of 
the state of the "Draw Altitude Lines" check box.

Selecting the "Azimuth" option from the "Labels" submenu displays the following dialog 
box:
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The radio buttons in the "Label with" box control the type of azimuth labelling, and 
determine which (if any) of the other values in the dialog are used.

If the "Compass Points" button is selected, the horizon is labelled with the names of compass 
points, and the options in the "Compass Interval" section of the dialog are used.

If the "Azimuth" button is selected, the horizon is labelled with azimuth numbers (in 
degrees), and the options in the "Azimuth Interval" section of the dialog are used.

If the "Nothing" button is selected, the azimuth axis is not labelled, and the rest of the dialog 
is ignored.

The "Compass Interval" section of the dialog determines the labelling method used when 
"Compass Point" labelling is selected.  The radio buttons allow the labelling interval to either 
be determined automatically, or one of three manual intervals selected.

The "Azimuth Interval" section of the dialog determines the labelling method used when 
"Azimuth" labelling is selected.  The options allow the labelling interval to be either 
determined automatically, or specified manually by the value in the text field.

If the "Draw Azimuth Lines" box is checked, lines are drawn up from the labelled points on 
the horizon to the top of the map.

Colours....

This option allows the user to select the colours used for every item drawn on the map.  
When this option is selected, the following dialog is displayed:

To view or edit the colour of any map component, either double click on the name in the 
listbox, or move the listbox highlight to the name and press the "Edit..." button.  Either way, a
standard colour selector box will be displayed, letting you choose the colour for the item.

Notes:

1.  Pressing the "Cancel" button will restore all the colours to their previous settings, not only
the colour just edited.

Draw

Selecting this option will draw the map, using the current option settings.  You may press the 
F5 key as a "shortcut" for this option.
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9.  Using the Horizon Map

Once the horizon map has been created using the methods described in the previous chapter, 
it can be manipulated in various way.  This chapter describes the available options:

Setting the Visibility of Objects

The first section of the "View" menu contains a list of object names (stars, constellation 
names, etc), each of which has a tick alongside if that type of object is currently visible. 
Selecting any of these options will toggle the visibility of that type of object, and the map 
will be redrawn.

Changing the map scale

The "Zoom In" and "Zoom Out" items on the "View" menu may be used to change the 
magnification of the map.  The F2 and F3 function keys are shortcuts for these operations.  
When the map is first drawn, it is scaled so that the map exactly fills a maximized map 
window.  Every time "Zoom In" is selected, the size of the map increases by 50%, and the 
map is redrawn.  Every time "Zoom Out" is selected, the size is correspondingly reduced.

When the map is zoomed, the centre of the current window will remain stationary.  You can 
therefore zoom in a particular feature by first scrolling it to the centre of the window, then 
repeatedly pressing the F2 key.  To aid this process, a shortcut method has been provided to 
bring a point to the centre:

1.  Position the mouse pointer over the point on the map you would like to bring to the centre.

2.  Press the right mouse button.  A pop-up menu will appear at the mouse position, 
containing a number of items.  The exact number of items on the menu will depend on where 
the mouse is located.

3.  Select the "Centre" item with the left mouse button.  The window will scroll to bring the 
chosen point to the centre of the map.

Note that the map will not scroll past its edges (the boundaries of the full-screen normal size 
map).  In order to bring a point to the centre of the map it may, therefore, be necessary to 
zoom in one or more times first.

Identifying Objects on the Map

To display a dialog box showing information about any star or planet on the map, move the 
mouse pointer over the star or planet, and press the right mouse button.  A pop-up menu will 
appear.  Select either "Identify Star" or "About <planet name>" as appropriate.
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If, for example, you ask for information about Rigel - the bright star at the bottom right of 
Orion, the following dialog is displayed:

The exact information displayed will obviously depend on the star, but note the following:

1.  The star's SAO catalog number is displayed in the dialog box title.  The SAO number is 
the way that SkyMap identifies the star internally - all other information is derived from this.

2.  The top section of the dialog displays the identify of the star.  The same star can be 
identified in a truly bewildering variety of different ways.  SkyMap attempts to show a few of
the more popular names for the star:

The first line of the dialog always displays the name of the constellation that the star is in.  In 
the case of a star (such as this one) which has either a Bayer letter or Flamsteed number, the 
star's constellation is actually stored in the database.  In cases where this information is not 
present, the constellation is computed from the star's location, using the official IAU 
constellation boundaries.

The next line, if present, displays the "proper name" of the star - Rigel, in this case.  Note that
many star names are derived from Arabic and, as such, have a number of alternate English 
spellings.  In the case of such stars, the name that SkyMap displays may well be slightly 
different from the name your reference sources show.  All that means is that I used a different 
reference book!

Next are shown the star's Bayer letter (b Orionis) and Flamsteed number (19 Orionis), if 
present.

Finally in the initial section of the dialog, the star's visual magnitude is shown.

3.  The lower section of the dialog shows the position of the star in several different 
coordinate systems.

First, the star's catalogue position is displayed - the right ascension (RA) and declination to 
epoch J2000.0.  This information is taken straight from the SAO catalog and contains no 
position corrections.

Finally, the current altitude and azimuth as seen from the observer's location are displayed.

If information about a planet is requested, a more complex dialog with multiple screens of 
information is displayed.  For example, requesting information about Mars initially displays 
the following dialog:
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The buttons on the right side of the dialog are used to select the different screens - the "Earth"
(geocentric) data screen is displayed initially.  The names "Local",  "Earth", and "Sun" refer 
to the position of the viewer, eg, the "Sun" button displays heliocentric information.

The "Local" displays information about the planet as seen from the observer's location at the 
current time (for which the map is displayed).  The following information is displayed:

1.  The altitude and azimuth of the planet as seen from the observer's location at the current 
time.

The "Earth" screen (initially displayed) displays information about the planet as seen from 
the centre of the earth - ie, geocentric information.  The following information is displayed:

1.  The apparent geocentric right ascension and declination, referred to the true equinox and 
ecliptic of date.

2.  The constellation the planet is in.

3.  The true (geometric) distance of the planet in both astronomical units (exactly) and 
millions of km (approximately).

The "Sun" screen displays information about the planet as seen from the centre of the Sun - 
ie, heliocentric data.  The following information is displayed:

1.  The apparent ecliptic longitude and latitude of the planet, referred to the true ecliptic of 
date.

2.  The geometric radius vector of the planet (ie, the distance between the planet and the Sun) 
in both astronomical units (exactly) and millions of km (approximately).

The "Physical" screen displays physical information about the planet.  The following 
information is displayed:

1.  The visual magnitude.

2.  The phase.

3.  The apparent diameter, in seconds of arc.

4.  The phase angle, in degrees.  This is the angle between the Earth and Sun, as seen from 
the centre of the planet.
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5.  The elongation, in degrees.  This is the angle between the planet and the Sun, as seen from
the centre of the Earth.

6.  The light time in hours, minutes, and seconds.  This is the time taken for light to travel 
from the planet to the observer, and is an indication of the "age" of the view we see of the 
planet.  Eg, if the light travel time for Mars is shown as 5 minutes, this means that we are 
seeing Mars as it actually was 5 minutes ago.

Printing the Map

To print the map, choose the "Print" option from the "File" menu.  This will display a 
standard "Print" dialog, allowing you to select the print options (printer, resolution, etc) in the
usual way.

Notes:

1.  By default, the map is printed in landscape orientation.  If you wish to change this, use the 
"Print Setup" option.

2.  Currently, the map is always printed at the normal 100% zoom factor - ie, the scale in use 
on the screen is ignored.  This issue will be addressed in a future release of SkyMap.

3.  The map is printed in black and white, using black symbols on a white background.  
Options for printing maps in colour will be added in a future release of SkyMap.
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